[Dirvish] Backing up Windows computers

Eric V. Smith eric at trueblade.com
Sun Mar 9 22:57:52 UTC 2014

On 03/09/2014 06:24 PM, Gibson McNeil Boyle wrote:
> I have dirvish setup and tested using both ssh (copssh) and rsync
> (cwRsync). Both utilities are available from www.itefix.no. The setup is
> backing up a windows folder to a NAS (linux platform). Tests copying
> files with and without ssh (rsync daemon) were successful. 
> To overcome the issues associated with rsync while copying open/locked
> files, I tried out Eric Smith's tb-rsync-vss-32 wrapper. Unfortunately,
> dirvish returned broken pipes errors using ssh. I used a default.conf
> file very similar to the example provided in the Bitbucket article.

Hmm. There's some way to have tb-rsync-vss-32 produce a log file.
Coincidentally, I'm setting up a new Windows machine so I have occasion
to look into the source code this week. I'll report back on my progress.

> I shall be grateful to hear about the experience of other users with
> this tb-rsync-vss utility..
> 1. Is it necessary that I must use cygwin, sshd and rsync instead of
> copssh and cwRsync?

I don't see why cygwin's versions of these tools would be required. The
code does nothing cygwin specific, that I know of. It does know about
cygwin specific paths, but there's a documented way to turn that off.
It's probably not well tested.

> 2. If the tb-rsync-vss utility and its convoluted parameters is a
> logical replacement for rsync, should it not be useable in all cases
> where rsync is used including when run as a daemon in a secure network
> possibly with the addition of an extra colon at the beginning of the
> tree string in the default.conf file?

Heh. "Convoluted" is an understatement. I'm open to ideas on making it
simpler, but if you live with the restriction that all of the
configuration must be done on the side running dirvish and passed via
"rsync" command line parameters, I don't see what other choice you have.

I don't think it could replace the "rsync as a daemon" scenario, because
it doesn't listen to any sockets. It relies on ssh starting it up,
thinking it's a non-daemon version of rsync. Maybe it could be made to
work with inetd doing the listening, but I've not thought it through
(nor tried it, obviously).

I hope that helps. When I get my new instance installed, I'll let you
know. I'll be running the 64 bit version, but the source code is
identical between the two versions.


More information about the Dirvish mailing list