[Dirvish] run from cron fails

Brian Brian_dorling at t-online.de
Wed Sep 26 14:00:31 UTC 2007


Kevin Foote wrote:
> Hello all - very quirky situation here. I have a proper dirvish setup 
> which works ...
> bank and valuts defined correctly etc..
> 
> I am trying to run via cron at the wee hours of night and it fails with
> dirvish error 127 .. this is a rsync error supposedly.
> 
> I have verified this a few ways. first running dirvish-runall via cron 
> faild with
> not really any indication why .. error number was 4 the number of valuts 
> I was starting.
> I then replaced the dirvish-runall command in my script to do
> dirvish --vault <name> for each vault.. This is where I can now see the 
> 127 error.
> 
> This is even more frustrating as when I run each vault from a console it 
> works just fine
> dirvish --vault <name>   this does what its supposed to, also 
> dirvish-runall does what it is
> supposed to from a console aswell.
> 
> Im guessing the issue is with cron or env or something of that nature.. 
> has anyone
> else seen this as an issue? Very bewildering..
> 
> This is all a local backup to a usb attached drive.
> OS: RHEL4u5
> 
> 
> -- 
> :wq!
> kevin.foote
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Dirvish mailing list
> Dirvish at dirvish.org
> http://www.dirvish.org/mailman/listinfo/dirvish
Hi,
I had a similar problem on a Slug running unslung V5.5. Running Dirvish 
from the command line was always OK, via cron it broke about 33% of the 
time. In my case I found two solutions:

1. Use Cron to send the Dirvish command to atd.
2. Upgraded Cron and the newest version for unslung worked OK.

If yours breaks each time then I would suggest a configuration problem 
is more likely.

Cheers Brian



More information about the Dirvish mailing list