[Dirvish] Re: Use existing backup as initial image

Noel Kelly nkelly at citrusnetworks.net
Tue Jan 16 05:36:06 PST 2007


Noel Kelly wrote:
> We now have a requirement to backup some data from another office.  This 
> office has an ADSL line and rather than initially trying to suck all the 
> data the wrong way up the data pipe, I rsync'ed it to a removeable disk 
> (FAT32).
> 
> I have now created the first dirvish image using --init and pointing to 
> the data on the removeable disk.  This works fine and I get a new image 
> created.
> 
> However the problem is that when I run point dirvish (via ssh) at the 
> remote server it insists on copying over all the data again.  I think it 
> sees the image that has come off the removeable disk as it does not 
> complain about there not being any default images etc and/or ask for 
> --init.
> 
> If I copy over a small subset of data (via ssh) using --init and then 
> try subsequent backups it works fine so I my actual config mechanism works.
> 
> I tried editing the removeable disk's --init image 'summary' file to 
> reflect all the same hostnames etc as used during the network copy but 
> this did not help.
> 
> The removeable disk is FAT32 and as such the permissions and ownership 
> did not transfer properly.  I thought that rsync compares the file sizes 
> rather than meta data but perhaps perms/owner make it see it as a 
> totally new file?  I have tried doing this with rsync but it did not 
> make any difference.

I have tried this procedure again using a removeable disk formatted with
ext2 and this time it seems to work with no problems.  In retrospect I
guess this is to be expected as the rsync options to preserve ownership
etc will baulk at something coming off a FAT32 drive.

So to get an initial image from a Windows machine onto a Linux server
will mean using the ext2ifs driver?  (www.fs-driver.org)

Cheers
Noel






More information about the Dirvish mailing list