[Dirvish] Use existing backup as initial image

Noel Kelly nkelly at tarsus.co.uk
Fri Jan 12 13:38:34 PST 2007


I have been using Dirvish successfully for a year or so now on our 
internal network and it works great.

We now have a requirement to backup some data from another office.  This 
office has an ADSL line and rather than initially trying to suck all the 
data the wrong way up the data pipe, I rsync'ed it to a removeable disk 

I have now created the first dirvish image using --init and pointing to 
the data on the removeable disk.  This works fine and I get a new image 

However the problem is that when I run point dirvish (via ssh) at the 
remote server it insists on copying over all the data again.  I think it 
sees the image that has come off the removeable disk as it does not 
complain about there not being any default images etc and/or ask for --init.

If I copy over a small subset of data (via ssh) using --init and then 
try subsequent backups it works fine so I my actual config mechanism works.

I tried editing the removeable disk's --init image 'summary' file to 
reflect all the same hostnames etc as used during the network copy but 
this did not help.

The removeable disk is FAT32 and as such the permissions and ownership 
did not transfer properly.  I thought that rsync compares the file sizes 
rather than meta data but perhaps perms/owner make it see it as a 
totally new file?  I have tried doing this with rsync but it did not 
make any difference.

Anyone have any ideas?  Is there a particular procedure for this?  If I 
can get it to work then I'll add something to the wiki.


More information about the Dirvish mailing list