[Dirvish] Re: curious problem - dirvish does nothing when run

Michael Nelson michaelnel at comcast.net
Fri Jan 12 09:11:29 PST 2007


On Fri, Jan 12, 2007 at 09:38:18AM -0700, hanj wrote:

> I ran into this exact problem a few weeks ago. One box was doing
> 'nothing' from cron but cmd worked. What I ended up doing to solve it
> was update my env when cron was executed. Not sure why that fixed
> it.. but it did the trick.
> 
> Try adding this to your cron...
> 
> source /etc/profile; env-update; /usr/sbin/dirvish-runall;
> 
> Might be worth a try.

Thank you.

I wrote a little script called dirvish-cron to run the stuff and now it
works fine:

#! /bin/sh

PATH=/usr/bin:/usr/sbin:/sbin:/bin

dirvish-expire
dirvish-runall

So, I am not going to screw around with it any more, since it's working.
BTW, with all the warnings you get when using it, I can see why they left
off the perl -w switch.  Pretty ugly! <grin>

-- 
If a kid asks where rain comes from, I think a cute thing to tell him is
"God is crying." And if he asks why God is crying, another cute thing to
tell him is "Probably because of something you did." -- Jack Handy

San Francisco, CA


More information about the Dirvish mailing list