[Dirvish] Re: curious problem - dirvish does nothing when run from cron

Michael Nelson michaelnel at comcast.net
Fri Jan 12 06:54:12 PST 2007


I added /usr/local/sbin to the PATH in /etc/crontab, restarted crond (I know,
but just to make sure), and changed the invocation of dirvish-runall to spit
out the return code.

I rm -r the directories for today (result of my having run dirvish-runall
from the command line successfully) and changed the time of the cron run and
waited.

It emailed me this:

#Subject: Cron <root at seahunt> /usr/local/sbin/dirvish-runall; echo "return was: $?."
#To: root at seahunt.dyndns.org
#X-Sorted: Admin
#
#06:40:01 dirvish --vault root
#06:40:01 dirvish --vault home
#06:40:01 done
#return was: 2.

Note that it took apparently less than one second to run, and there were no
errors reported, even though the return code of 2 indicates both jobs
failed.  It doesn't say why, just that they did.

I checked for the directories... they were not created.

I ran it from the command line again:

seahunt:/scsi/extra/snapshot/seahunt/root # dirvish-runall
06:45:44 dirvish --vault root
06:45:54 dirvish --vault home
06:46:10 done
seahunt:/scsi/extra/snapshot/seahunt/root # 

Notice that now it DID take some time to run (not much, but I am not backing
up much).  Further, the backup directories for today were created when I ran
it from the command line.

Michael

-- 
If a kid asks where rain comes from, I think a cute thing to tell him is
"God is crying." And if he asks why God is crying, another cute thing to
tell him is "Probably because of something you did." -- Jack Handy

San Francisco, CA


More information about the Dirvish mailing list