[Dirvish] Re: curious problem - dirvish does nothing when run from cron

Michael Nelson michaelnel at comcast.net
Fri Jan 12 04:59:47 PST 2007

I had this same problem.  When dirvish-runall ran from cron it took zero
time to run and did nothing, but produced no errors.  If I ran it from
root's shell it ran fine.

I had installed it in /usr/local/sbin, which seemed like a good place for
something like dirvish, but /usr/local/sbin was not listed in the PATH in
/etc/crontab.  /usr/local/sbin *is* in root's PATH as set up in root's
.bashrc though.  

Unfortunately, at least in SUSE 10.2 the crontab PATH setting is absolute,


I think it would be better for it to be:


... so it would pick up any path additions that had been done in the root

I wish that if dirvish-runall was unable to find dirvish it would spit out
an error.  I could have fixed it days ago if it did.

If a kid asks where rain comes from, I think a cute thing to tell him is
"God is crying." And if he asks why God is crying, another cute thing to
tell him is "Probably because of something you did." -- Jack Handy

San Francisco, CA

More information about the Dirvish mailing list