[Dirvish] dirvish: no incremental on Mac OS 10.4

Bernd Haug haug at berndhaug.net
Fri Oct 27 04:54:09 PDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Richard Geoffrion wrote:
> Ok..... I have the -E options.   I'm running 10.4.7 and have rsync
> version 2.6.3 protocol version 28.  Even WITH the -E option I am getting
> FULL backups instead of incremental (or maybe because of it).    Now...
> the ORIGINAL machine I was setting up with dirvish has a different
> version of rsync  (2.6.6 protocol ver. 29)  I'm trying to locate it now.

Thanks for the info; so getting a more recent rsync patch won't help
I guess. :(

> Researching the following links.
> http://www.quesera.com/reynhout/misc/rsync+hfsmode/  patched rsync+hfsmode
> hmm.. I wonder if my 2.6.3 version of RSYNC ..the one WITH the -E
> option  has the same functionality as the 2.6.6 version on the other
> mac.  hmmm...
> I'm going to download the rsync port from http://www.darwinports.com/
> and see how that works.

So, judging by the end of your mail, still nothing?

> The thing with MAC files is that the OS seems to be always touching
> them....this means that they always seem new.  If it's new, dirvish will
> wanna back it up.

Yes...but even when the modification and change dates didn't change,
they still get copied. It's weird. Is there a date stored in the
resource fork as well?

If so, how does rsync get to it? It only seems to use the fake Unix
semantics.

> my brain hurts and my eyes are dry.  apple/max/HFS aside... which time
> does rsync compare??   MTIME?  CTIME? ATIME?   isn't it mtime?  Well
> then I wonder if the mac keeps modifying its mtime. (I know not what I
> say..but in my current condition it SOUNDS good).

Should be mtime. ctime is metadata change, and atime is readonly
access, which shouldn't figure into incremental backup logic.

Why the OS would open files for writing(!) randomly, changing the
mtime, I can't understand, but given the way they implemented
Aliases apart from softlinks and how they botched hardlinks (see my
other message, I wrote those in parallel) I wouldn't put it past them.

> Ok...well.. STILL no luck.  version 2.6.8 from darwinports.com is
> exhibiting the same symptoms -- FULL coppies, not incrementals
> .  this is either  WITH or WITHOUT the  -E rsync option.
> Does ANYONE have dirvish working on mac?

I'm trying to UFS next, results in a few.

Yours, Bernd
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFQfNhjAQAqv3HuJURAqmfAJsF105Y07NHOb3nwPWcMVLd2f3BDACgsdYm
InS1A6EqixnW0fl+TOm4hx4=
=Oqgl
-----END PGP SIGNATURE-----


More information about the Dirvish mailing list