[Dirvish] Baffling rsync/ssh/Cygwin problem

Joseph Lamoree joseph at lamoree.com
Fri Mar 25 22:48:34 PST 2005


I'm struggling with a problem that prevents me from backing up a 
Windows 2000 machine that has Cygwin installed to provide OpenSSH 
(v3.9p1) through which rsync (v2.6.3; protocol v28) does it's magic. My 
Dirvish server is a RHEL 3 Update 4 machine with rsync (v2.5.7; 
protocol v26) and  OpenSSH (v3.6.1p2).

The symptom is that the dirvish backup job stops after only a little 
work, and never finishes. It only places a handful of files in the 
tree. I did some troubleshooting by running rsync manually with extra 
verbosity. Here's an example:

rsync -vvv --recursive --times --one-file-system \
    --perms --owner --group --numeric-ids \
    --rsh=/usr/bin/ssh --stats  \
    Admin at ll-app-01:/cygdrive/d/ \
    /backup/dirvish/ll-app-01/ll-app-01-d/test

It chugs and churns, but halts after a few minutes. I've left it at 
this point overnight, and nothing further happens. There aren't any 
informative errors on either the client or the server. I've done this 
several times, and it seems to get about 5 Mb worth of stuff. I've 
tried making the backups go to a traditional SCSI array, as well as to 
an external USB2 enclosure. I've tried doing a giant transfer using scp 
from the backup target, and it works without a complaint. I even tried 
making a backup of the target machine using tar through ssh:

ssh -l Admin ll-app-01 "cd /cygdrive/d/; tar zcf - *" > backup.tar.gz

That worked like a champ, even when the destination was the relatively 
slow drive inside the USB2 enclosure.

I realize this isn't a problem caused by Dirvish, but I hoped someone 
might have experienced troubles like this and have some advice.

Thanks.

--
Joseph Lamoree



More information about the Dirvish mailing list