[Dirvish] Strange rsynch problem.

Michael Medin michael at medin.name
Thu Jul 21 12:17:48 PDT 2005


Hi,

I get a rather strange rsync problem. When I run rsynch manually it 
works like a charm even if I use the same command as Dirvish but always 
when run by dirvish it returns an error.

*First off some system information:
*# dirvish --version
dirvish version 1.2

# rsync --version
rsync  version 2.6.5  protocol version 29
Copyright (C) 1996-2005 by Andrew Tridgell and others
<http://rsync.samba.org/>
Capabilities: 64-bit files, socketpairs, hard links, symlinks, batchfiles,
              inplace, IPv6, 64-bit system inums, 64-bit internal inums

rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
are welcome to redistribute it under certain conditions.  See the GNU
General Public Licence for details.

# uname -a
Linux gotrek 2.6.10 #6 Tue Mar 15 20:27:29 CET 2005 i686 unknown unknown 
GNU/Linux

# more /etc/slackware-version
Slackware 10.1.0

*Then some error details:
*more 2005-07-21/rsync_error

*** Execution cycle 0 ***

rsync: writefd_unbuffered failed to write 4 bytes: phase "unknown" 
[receiver]: Broken pipe (32)
rsync error: error in rsync protocol data stream (code 12) at io.c(1099)

I have "debugged" the code and located the problem to this code segment:

        open (INHOLD, "<&STDIN") or seppuku 20, "Cannot open stdin";
        open (ERRHOLD, ">&STDERR") or seppuku 20, "Cannot open stderr";
        open (STDERR, ">$err_temp") or seppuku 20, "Cannot open log";
        print STDERR "         \n" x 6553;
        seek STDERR, 0, 0;

        open (OUTHOLD, ">&STDOUT");
        open (STDOUT, ">$log_temp");

        $status{code} = (system(@cmd) >> 8) & 255;

/* The above generates the error */


The rather interesting thing is that if I add a print statement for the 
command line (rsync) and exit the code. And then run rsync manually 
(using the exact same command line) it will run fine:

# rsync -vrltH --delete -pgo --stats -D --numeric-ids -x 
--exclude-from=/mnt/sda1/test/heroin-root/2005-07-21/exclude heroin:/ 
/mnt/sda1/test/heroin-root/2005-07-21/tree
receiving file list ...
...

I have also noted on the client i try to run the backup on no "login" is 
logged when the command is run by dirvish (whilst when I run it myself 
it logs in to the remote server).

Anyone have any ideas ?

// Michael Medin



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.dirvish.org/pipermail/dirvish/attachments/20050721/52f2d1af/attachment.htm


More information about the Dirvish mailing list