[Dirvish] dirvish/rsync thru ssh

Mike Miller dirvish at mikemiller.net
Thu Jul 14 17:11:49 PDT 2005

Ok, I obviously don't know what the hell I'm doing.

I have data on a remote host I want to back up along
with some local file systems.  I followed the directions
at http://www.jdmz.net/ssh/ to set up ssh to allow for
passwordless validation and access to the remote host,
and I was able to successfully run the rsync command
specified in these docs:

rsync -avz -e "ssh -i $HOME/cron/morpheus-rsync-key" REMOTE_USER at REMOTE_HOST:/path/to/data /local/backup/path

It worked!

But I can't get it to work through dirvish.

My /backup/web/dirvish/default.conf file says:

   tree: /path/to/data
   xdev: true
   index: gzip
   image-default: %Y-%m-%d

and when I run 'dirvish --vault web --init'

I get a password prompt. :-(
(Yes, it works if I type the password).

Looking at the /backup/web/2005-07-14/summary file, it
tells me the rsync command being run is:

rsync -vrltH --delete -pgo --stats -D --numeric-ids -x --exclude-from=/backup/web/2005-07-14/exclude REMOTE_USER at REMOTE_HOST:/path/to/data/ /backup/web/2005-07-14/tree

What am I missing?  I'd really like to automate this.



More information about the Dirvish mailing list