[Dirvish] Error: no images for branch default

Keith Lofstrom keithl at kl-ic.com
Sat Jan 22 21:30:33 PST 2005


On Sat, Jan 22, 2005 at 08:31:20PM -0800, tony wrote:
> 
> I have created all the scripts base on the article but I receive the 
> following message
> when trying to backup the dirvish server
> "suse-root:default:2005-0122-1955: Error: no images for branch default"
> Also if I run dirvish-runall I get the same error message.
> What would cause this?

Your vaults didn't get initialized yet.

After you have set up the directory structure of banks and vaults, the
/etc/dirvish/master.conf file, and the ../BANK/VAULT/dirvish/default.conf
files (which it seems that you've done), you need to do a:

   dirvish --init --vault VAULT  

... for each of your VAULTs .  You can do this with a script like:

  for VAULT in tom_root tom_usr harry_root harry_home
  do
    dirvish --init --vault $VAULT
  done

This will thrash and thrash, and move data at about 10GB per hour over
a 100BT network.  USB2 connected drives will slow it down more.  But
hey, what are weekends for?  After the initialization, future backups
will go *much* faster.

I hope that gets you going.  Welcome to Dirvish!

Keith

P.S.  Thanks for a descriptive subject line and a concise writeup of
your problem.  Meanwhile, I left an "--init" out of the initialization
script.  I will post a correction to the site.

-- 
Keith Lofstrom          keithl at keithl.com         Voice (503)-520-1993
KLIC --- Keith Lofstrom Integrated Circuits --- "Your Ideas in Silicon"
Design Contracting in Bipolar and CMOS - Analog, Digital, and Scan ICs


More information about the Dirvish mailing list